• Update: This issue is no longer relevant. 🙂

    Hi 🙂!

    I'm trying to update the Espruino Pico by following the "Advanced Reflashing" guide using ST's DFU utilities.

    Attempting to flash
    To later verify the flash, I'm using the v. 2.05 binary, since it runs v. 2.06 right now.

    I then did:

    1. Put the device into DFU mode by holding the button, connecting USB, releasing the button. I shorted the jumper on the bottom before hand as instructed.
    2. Selected the device in the "DfuSe Demo" utility from ST. Then selecting the .dfu-file (the .bin converted by using the "Dfu file manager" utility from ST)

    The result looks OK I guess 🤷♂️:

    Verifying the flash
    I take my Pico out of DFU-mode, and connect to it using the "Espruino WEB IDE", but it still shows up as FW v 2.06 😥.

    I also tried
    ... the command line tool using the command "DfuSeCommand -c -d --v --fn espruino_2v05_pico_1r3.dfu" which also claims to succeed.

    I hope someone is able to help me out 😊!


    2 Attachments

    • flashing.png
    • verifying.png
  • This issue is no longer relevant. 🙂

  • Hi - just wondering - why is it not relevant now?

    Where did you get the .dfu file from? I think generally the files I produce are .bin.

  • I had a deadline creeping up on me, so I decided to give it another go myself. I averted the issue by using dfu-util on Linux 🙂. So sorry to say, no bounty this time 😊.

    The tool from ST seems to only accept .dfu-files, and theres another utility in the bundle to convert from .bin to .dfu.

About

[NOT SOLVED] Not able to update the Espruino Pico firmware using ST's DFU utility

Posted by Avatar for user114366 @user114366

Actions