[Solved] Firmware update fails at 2%

Posted on
  • Hi there,

    I followed the instructions to update firmware for Bangle.js, but the connection between the NRF tool app and my Bangle got lost at around 2%... the app reported an error and my bangle reports the message


    Any ideas of what I might gone wrong?


    P.S. I've tried the process a few more times with the same results... error around 2%.

  • That's an odd one. Please could you try re-downloading the firmware file from Espruino.com? Also if possible try flashing with another device, and keep the two devices close (1 foot ideally) during the whole process.

    On some devices WiFi can really mess with the Bluetooth, so you could always try disabling WiFi on your phone

    While it likely will have stopped Bangle.js from booting, it's nothing to worry about. The bootloader will stay on there so as soon as you can send a full firmware it'll start working again.

    Also, the initial Bangle.js firmware was loaded wirelessly using that bootloader on your watch - so we know your device is capable of taking a firmware update.

  • Gordon,

    Thanks for the quick reply. I got a hold off a second device and tried the whole process again (making sure wifi was disabled). It worked!

    Thanks again.

    P.S. I'll try to mark this post as solved.

  • I'm sorry, Gordon. I do not know how. Would you be so kind to mark this issue as resolved for me?

    Thanks one more time.

  • That's great - thanks for letting me know!

    Just marked as solved - nothing fancy I'm afraid, you just edit the post's title :)

  • FYI: same happened to me when upgrading to v2.06.
    I did the usual: download zip file from espruino.com/download on my phone and used nRF Toolbox.
    I didn't pay attention to it sitting next to me because for the previous time that worked fine.
    When I looked at the watch a minute later it show the same error message from OP.
    So I tried again and it stopped with an error at 2%.
    Error messages where something of the line of "Invalid parameter" and something else. I tried a couple of times without success.
    What eventually helped was switching BT on the phone on/off again.

  • @Raik thanks - what OS is your phone running?

  • what OS is your phone running?

    Android 8.0.0

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

[Solved] Firmware update fails at 2%

Posted by Avatar for ElmerHomero @ElmerHomero