[Solved] Banglejs ist out of memory

Posted on
of 2
/ 2
  • Hi,
    I have uploded some apps and now i Just can't get into the menue anymore. If i press button 2 nothing happens (the button works) or sometimes there is an error message that ist related to low memory.
    I think i uploaded the wrong application but cannot say wich one it was.
    So now i obviously cannot get into ble conection or make it programmable.
    What i tried was Pressung Button 1 and 2 for the rescue mode. I can get a connection here once a time i restart it. But it gets stuck while loading the app list.
    I also tried all other options like installing default Apps, deleating all Apps and so on. Not even setting clock time works. The Connection to the IDE also Breaks Up with an Error Message. And a firmware update Breaks Up as well. My Version is 2v05 e5:04:67:a7:c4:ec
    I'm out of Options and need Help!

  • Hi - did you ever successfully update the actual Espruino firmware? https://www.espruino.com/Bangle.js#firmw­are-updates

    That would be the key here - generally if you can do the reset without loading code from https://www.espruino.com/Bangle.js#reset­ting-without-loading-any-code you can reprogram Bangle.js however you want, but if Bluetooth/Programmable was off in settings before this happened and you're on the original firmware then you can hit issues and you'll have to update the firmware.

  • Hi Gordon,
    Thank you for the Post.
    I forgot to mention that i tried nrf Toolbox as well. But this also did not work. The update fails and gives back GATT Error.
    I can find the device and try to connect but somehow everything i try Breaks up with an error.
    And no, i have not updated so far.

  • i tried nrf Toolbox as well

    And you definitely did that when the Bangle was in bootloader mode? Do you think you could post up a video?

  • Hi Gordon,
    Heere is a video of what is happening or not happening .

    1 Attachment

  • Ahh ok, so I could be wrong, but this looks a lot (from the almost instant -> Bluetooth message on Bangle.js and the need to restart) like some other device is trying to connect to the Bangle.js as soon as the Bangle.js advertises itself...

    Do you have Gadgetbridge installed on your phone? Also is it possible you have 'paired' it with your phone/PC/laptop - which might have caused that to try and connect to the Bangle whenever it sees it?

  • I ran into this problem, too. I thought it might be defective apps, but I simply had too many apps/watch faces loaded onto the watch. The RAM widget is helpful in knowing when the limit is about to be reached.

  • Hi,
    Yes i tried to make an Update via gadgetbridget Like described as well and it Stopps with GATT error.
    I tried to connect while keeping it away from other devices but still same issue.

  • And what was your solution then?

  • Unloading apps/watch faces/widgets to the point the RAM was at approximately 60-65% (not red). Once that happened, I was able to enter the menu.

  • Thank you for your reply. Thats the Point. I can't unload the Apps anymore due to an Error.

  • Please can you:

    I think most likely Gadgetbridge was auto-connecting to your Bangle whenever it saw it, which was stopping you being able to update

  • I'll give it a try, and report back.
    Thank you!

  • Nope, that didn't work. Nrf Toolbox still stopps with a GATT error and deleating apps still not working. And i have also still the problem that i can find the device only during the bootup process and not after it booted to the safe mode.

  • Have you tried rebooting your phone or if possible using another device with NRF Toolbox? It's possible it is some issue with Bluetooth on the device you're using for flashing.

    The whole 'can't connect after safe mode' is a known issue that was fixed about a week after the first release - so if you can get a new firmware on it I'm pretty sure that'll fix everything else.

  • Hi Gordon,
    After a Lot of Trial and error i got the Default Apps Back!
    Solution was to restart into safemode again a second time after trying to Connect. Somehow this gave a kick in its ass.
    Now i would Like to Update the Firmware via nrf Toolbox. But here i have another problem. The update fails now due to a new Error "DFU charakteristics not found"
    Ist this a nown Problem?

  • "DFU charakteristics not found" ... Ist this a nown Problem?

    I haven't come across it before. Are you sure you're connecting to a device called DfuTarg (if it says 'Bangle' you're not in bootloader mode).

    Also try disabling and re-enabling bluetooth on your phone, as it may be the phone itself got confused by the same device suddenly having different characteristics after restarting in bootloader mode.

  • Hi,
    No, i never saw DfuTarg on it. It always show the same device name as the App Installer. But i'm defenately in bootloader mode.

  • I use libary Version 1.10.0.

  • I updated to Version 2.9 but still the same.

  • it may be the phone itself got confused by the same device suddenly having different characteristics after restarting in bootloader mode.

    nordic bootloader typically increases mac adddress by one if the name is DfuTarg to avoid this (well, if it is not buttonless update where it shares bonding info,keeps same mac and name and implements service changed service instead)

    EDIT: well at least that is what the SDK11 legacy bootloader does, not sure about secure one now

    yes, it is here https://github.com/espruino/Espruino/blo­b/master/targetlibs/nrf5x_12/components/­libraries/bootloader/ble_dfu/nrf_ble_dfu­.c#L735
    but I see no conditional code there like in sdk11 bootloader, there it 'advertises openly' and changes name to DfuTarg only if it is not buttonless update

  • I never saw DfuTarg on it. It always show the same device name as the App Installer. But i'm defenately in bootloader mode.

    What does it show on the Bangle.js screen? The Bangle.js logo? If so that's not the bootloader.

    If it's not advertising 'DfuTarg' I'd be pretty sure it's not in bootloader mode.

    I use that same bootloader to upload Bangle.js firmware to each watch I ship out, so I'd be pretty sure it works too.

  • I thank you again for your patience!
    It is flashed now!
    I hope this will not happen again.


  • Great! What was the issue? Was it that it wasn't in bootloader mode?

  • Yes, you really have to Count the seconds, otherweise you geht into the normal secure mode but not into bootloader. Maybe some Screenshots in the description Page would be helpful.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

[Solved] Banglejs ist out of memory

Posted by Avatar for Mateus @Mateus