Bricked two MDBT42Q modules

Posted on
  • Hi All,
    I come back to my MDBT42Q project after quite a few months break.
    I attempted to update to the latest firmeware but I seemed to have bricked both the MDBT42Q modules I have. I'm using the Web IDE and it seems to go fine but immediately return with this error...

    "Sorry, the firmeare update has failed.
    The rror was: Error: Data object does not match the firmware and hardware requirements, the signature is wrong, or the parsing command failed"

    I've attached a screen shot.

    Note, they connected fine before I tried to flash them. I'm sure I must be doing something silly.
    Anyone know how to recover from this.
    By the way, I'm on Mac, in case that matter.


    1 Attachment

    • Screenshot 2020-04-27 at 17.47.43.png
  • Wow, that's a new one!

    Please could you try updating with nRF connect on your phone?­-updates

    I imagine that'll solve the issue for you. I'm still not sure why but it does seem that the IDE's bluetooth firmware updater can be a bit unreliable on some platforms.

  • Yes, I was suprised as well, as previously doing lots of work with these including updating firmware and I've had to problems. Hmm, now I think about it and based on your comment, I may have done the update previously on a Winbows box, not Mac. Might try that as well. I'll also try your suggestion later today.

  • Ah, ha. Works fine using my Windows 10 machine. In fact, it did fail once with the same error but a lot further along in the process. Next try was successful. Mac fails almost immediately.

    So for information, I see this issue on a Macbook Pro running Catalina, Version 10.15.4.
    Thanks for your help.

  • Thanks! So much for web stuff behaving the same in different OSes :)

  • Tue 2020.04.28

    post #2   'Wow, that's a new one!'
    post #4   'Ah, ha. Works fine using my Windows 10 machine'

    Six months ago I effectively bricked my MDBT42Q. Chastised for using the update link, and the response In Bold Text I might add, was to avoid using that means to update, with the suggestions to use only an Android device.

    Unable to flash MDBT42Q with either Native WebIDE

    For giggles, I loaded up both the native and online WebIDE, and the DDL now (never tested then to see if the fix worked) populates with the nRF devices to flash and does download, which according to the fix, it wouldn't. I didn't dare go the next step, as I have no other means to correctly flash with an Android device, should that go belly up. So we now have another documented user attempting to update using the same instructions that forces one into that trap. My belief was that the option to fetch an nRF zip was defeated, although I am not abe to state for sure.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Bricked two MDBT42Q modules

Posted by Avatar for user97106 @user97106