Gadgetbridge cannot find Bangle.js

Posted on
  • I received my Bangle.js today (yay!) and cannot wait to start exploring it.
    At first I want it to replace the basic functionality my old smartband had, like showing notifications from my phone. I installed Gadgetbridge on my phone and connected the Bangle.js to my phone.
    However, when I try to add a new device to Gadgetbridge, it cannot detect the Bangle.js. Is there something (magical) I should do?

  • I had also spent some time on it. Make it connectable in the settings and for me it worked to disconnect an other existing BT connection and restart the watch while searching.

  • Have you used version 0.35 from Play Store? Bangle.js is only supported starting from 0.4.

    See this comment: http://forum.espruino.com/comments/15049­677/

    You'll need a version > 0.4 from https://gadgetbridge.org/ or F-Droid.

  • Hi all - I spent ages messing around with GadgetBridge yesterday, but solved the issue this morning. These are the steps I took:-

    1. Install GadgetBridge from F-Droid (at least ver 0.4)
    2. 'Reset settings' on Bangle, then restart it (turn off, back on)
    3. Turn bluetooth off then back on on phone.
    4. Go into GadgetBridge, it should show the Bangle, select it and then pair (this may take 2 or more attempts)
    5. Done!

    I'm now seeing battery status on my phone for the Bangle, and I just saw an email notification appear on my Bangle from Outlook! (albeit I need a magnifying glass to see it!)

    Cheers all :-)

  • Yeah, I've followed the same steps as @user110732 mentioned (I have the latest Gadgetbridge via F-Droid), multiple times, but it still refuses to connect.

  • I too am having difficulty connecting using Gadgetbridge v0.4 from F-droid. I've tried the suggested reset but no joy.

    1. I turn BlueTooth off on the phone then back on.
    2. On the Bangle under GadgetBridge I change "Connected" to "True", it shows a grey icon at the top.
    3. Start Gadgetbridge on the phone, Add device and then Start Discovery.
    4. GadgetBridge searches then nothing, and repeated Start Discovery don't appear to scan again, have to kill and restart the app.

    Stumped.

  • One other thing - if you have already paired it in BlueTooth, you need to unpair before step 3 in my list.

  • Brilliant, that appears to have done the trick, GadgetBridge has found it instantly. Thanks user110732 :-)

  • No worrys!

    Be aware... if your email is as active as mine, you'll want to filter the message in GadgetBridge otherwise your wrist will be vibrating every 10 seconds!

  • Ah, indeed! So after removing it from my list of earlier connected devices and restarting and stuff it now works!

  • Yeah, for me, it was simply updating to v4+. Pairing successful!... Buuuut no notifications :/

    Edit: Ah, didn't see the notification app in the Bangle.js app store.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

Gadgetbridge cannot find Bangle.js

Posted by Avatar for SLGeertsema @SLGeertsema

Actions