No Response (Solved)

Posted on
  • First of all, thank you for providing us with the Bangle in these trying times. We are being confined to Home for the next few weeks. Having something to experiment/play with really helps.

    Today, as a kickstarter-backer I received two watches. One of then works fine. On the other I did a firmware update. I used the file: After the update the watch shows a b/w logo and (small print...) > - bluetooth, which is all it does more or less.

    I tried to connect to it with the App-Loader. It cannot read the 'My Apps' list (Unexpected response). I tried checking the browsers console. The last line in there reads:
    Unable to decode "", got SyntaxError: Unexpected end of JSON input (puck.js:362)

    When connecting using the WEB-IDE I get (lower left corner of the screen):

    It seems like the watch is 'dead'??? Pressing B1+B2 and releasing in the right order gets the watch in DFU Mode, so I could flash something else, If only I knew what to flash...

    Thanks in advance for any help! I hope you all are well and safe.

  • Hi! I think it could be possible the watch was set up in settings to have Bluetooth off. Can you boot it back up to the watch (long-press BTN3), go into settings, and make sure Bluetooth and Programmable are set to on, and Debug messages are set to hide?

    If not it's possible it has managed to get in a state where the settings said to turn Bluetooth off, but then the watch firmware has got removed. Normally you'd be able to hold BTN1 while booting but the way I implemented to bootloader it'll run all the time. If that's the case let me know - I'll have to come up with a new watch firmware that doesn't load the bootloader if BTN1 is pressed.

  • Thank you for such a quick reply!!

    Bluetooth is on! However I cannot get into settings.

    Maybe I can clarify by showing some pictures...

    This is what the watch looks like after pressing B1+B2 and releasing them. I can contact the watch via Bluetooth, but cannot do anything usefull to it.

    This is what happens after long pressing B3. Pressing the other buttons has no effect.

    And after pressing B3 again it looks like this (BLE connected, queueing BLE restart...)

    After this nothing changes, unless I do the B1+B2 reboot again.

    So Bluetooth seems to be on, but not responding as it should. Is the bootloader really being loaded at all?

    Thank you for your patience!!

    Stay safe

  • Thanks - I think it's as I said above: The watch has been configured in such a way that Bluetooth has been disabled, but then the part of the bootloader that automatically loads apps has been wiped out - so you can't enter the settings app to change the settings.

    You mentioned you have two watches, and the other one is ok?

    I've got to get the remaining preorders out before the UK completely locks down, but I've made a note and later in the week I'll make some changes to the firmware. When that happens you'll be able to upload a new Espruino firmware which will then not load the JS bootloader code if BTN1 is held down, which will make it easy for you to boot up with BTN1 held (as you were doing), and then reload code with the app loader.

  • That would be nice, thank you.

    My son found another version of the firmware on /binaries/travis (I think 2v04.400) and flashed that. After that all was OK again. So the problem was in the 2v04.409 version.

    Maybe you could, later in the week, if time permits, also offer a release version of the firmware instead of just the 'cutting edge' on the Download page. That would probably help as well.

    In the meantime, thanks for your support.
    Stay safe!

  • Thanks! The issue might be that I made a few changes that I haven't yet pushed, because I want to do a 2v05 release for all devices, and some of them need tweaking (including the new Puck.js firmware). I'll get a new firmware out later this week

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

No Response (Solved)

Posted by Avatar for Kowsoleea @Kowsoleea