WebIDE relay broken?

Posted on
  • Hi there,

    is it possible that the relay on the WebIDE is broken?

    https://www.espruino.com/ide/relay only shows an "empty" page?

    1 Attachment

    • relay.jpg
  • What is this link for?

    does this work for you?


  • Sat 2020.02.22

    Although I am unable to verify on a smart phone, the above link wouldn't be expected to work within the PC browser. (appears to be Chrome on a PC image post #1)

    How to use Puck.js if your PC/Mac doesn't work with Web Bluetooth (Web IDE Relay)

    Is this the link you are after?


  • What is this link for?

    As @Robin pointed out with the link, its for relaying the IDE in case you don't have an working BLE adapter, just like my old laptop.

    Is this the link you are after?

    Well no, I'm trying to connect to my Pixl from my old laptop using my mobile phone with the relay page. I am pretty sure I already successfully tested this a while ago (maybe 2 months or so)

    The normal IDE works fine, but can't connect directly because my laptops bluetooth does not support LE and my BLE dongle is for some reason not recognised by Windows/Chrome

    EDIT: Btw: I can connect to the Pixl using the Chrome app on my phone with the WebIDE, but of course it's not really efficient to develop on it.

  • Sat 2020.02.22

    'my BLE dongle is for some reason not recognised by Windows/Chrome'

    So as the Chrome app functions on the mobile phone, it seems to be BLE that is the issue, also confirmed with the dongle now not functioning.

    FYI The last Windows10 update (~circa six weeks ago) had me in fits, and had to uninstall the BLE 4.1 driver and re-install it to get the external dongle to work again. If memory serves, I had to play with Settings >> Add Device (and remove - (un)pair) many times also. This might correspond with the 'maybe 2 months or so' successful comment.

    Incidentally, I just re-read the content at the link posted in #3 and the instructions there state the relay is for the phone and the WebIDE is for the PC running BLE. Now I'm a bit confused by the comment in post #4 'The normal IDE works fine' If it actually works 'fine' then it should connect, shouldn't it? . . . or, . . . did you mean it just launches without error?

  • As @Robin pointed out with the link, its for relaying the IDE in case you don't have an working BLE adapter, just like my old laptop.

    OK, that's a new nice feature for me.

    Chrome console log show's this error:

    app.js:376 Uncaught TypeError: Cannot read property 'domElement' of undefined
        at Object.addIcon (app.js:376)
        at Object.init (menuSettings.js:18)
        at initModule (espruino.js:49)
        at espruino.js:53
        at config.js:82
        at _get (config.js:57)
        at Object.loadConfiguration (config.js:73)
        at HTMLDocument.init (espruino.js:44)
        at fire (jquery-1.11.0.js:3099)
        at Object.fireWith [as resolveWith] (jquery-1.11.0.js:3211)

    1 Attachment

    • Bildschirmfoto 2020-02-23 um 08.05.45.jpg
  • Sorry for the confusion:

    So to make it clear:
    1) WebIDE on my laptop works in the sense that it can load properly. BUT I can't connect because the built-in bluetooth in my laptop doesn't not support BLE and the BT dongle doesn't work.
    2) The WebIDE on my phone using Chrome works; I can connect to the Pixl, but it's not comfortable to work with
    3) But: the relay page that used to work before on my phone doesn't work either on my phone and my laptop (just shows this empty page)


    I had to play with Settings >> Add Device (and remove - (un)pair) many times also.

    Strange thing is: the dongle (it's a TP Link UB400) is working fine with my desktop PC. But I just found no way to get it to work on my old HP 8440p yet. I guess this is a problem with USB ports/chipset. The dongle is connected and Chrome shows it in the chrome://bluetooth-internals page and in there also finds the Pixl. But then in the WebIDE popup it finds nothing (doesn't even seem to begin to search)
    -> hence, I tried to use the relay that doesn't work :(

    As @MaBe found out I guess this is a real issue with the page itself

    at Object.addIcon (app.js:376)

    Maybe this related to the changes that @Gordon made to the WebIDE by adding the storage icon?

  • Sun 2020.02.23

    'But then in the WebIDE popup it finds nothing'

    @Raik, What version of the WebIDE is in use? (e.g. is it the latest)

    seen on left hand panel on launch or WebIDE >> Settings >> About

    Is it the version downloaded from the Chrome store or the native app launched from the Win10 Start menu?

    Have you tried removing the 'pairing' and then re-adding Bluetooth devices?

    Win10 >> Settings >> Devices >> Bluetooth and Other devices >> Add a device

    I spent a good hour trying to find a method that worked, in order to get the WebIDE to see the newly detected devices. Remove all Espruino devices. Then Add to get Windows to reset the mess. This pain started after the last Windows10 update.

    P.S. I also have a three year old HP Nootebook laptop with a 4v1 BLE dongle

  • Thanks @Raik, I'll look into this. looks like some recent changes broke the relay page :(

  • Just fixed - I'll try and push an update later today with it in

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

WebIDE relay broken?

Posted by Avatar for Raik @Raik