Puck.js firmware update

Posted on
Page
of 2
Prev
/ 2
  • Wow, went back to 1v95 firmware and everything came back as it should working.. yaa.

  • Also just tried 1v96 to get larger memory format and that version doesn't work with the puck.js either. Have I received really old stock that won't upgrade past certain firmware? Only up to 1v95 operates normal.

  • That's strange. But if connection is lost during DFU (for example my phone has a short screen lock timeout, and just locked itself while sending DFU, breaking the DFU process), you can reconnect and continue where you were. In my experience Nordic's DFU software handles that automagically.
    But if I understand correctly, you have tried to send a different firmware version after the initial failure.
    Ooor, there is some chance of the DFU package is corrupted during download from the internet. Could you try to re-download the firmware (from espruino.com to your phone), and DFU that?

    Woh, this sentence sounds awkward, because you "download" twice :)

  • Hi - sorry you're having issues with this. Thanks for posting the logs, although I'm not seeing much in the way of an error there - I wonder if it actually logged the firmware update?

    As @AkosLukacs points out, if the upload fails then then you can normally just reconnect and resume the upload from where you left off.

    A failed upload will stop Puck.js from working as a Puck but you'll still be able to get the bootloader (appearing as DfuTarg, with the green LED) so you can finish the update and get it working. It sounds like you were just at that stage.

    Adafruit have pretty up to date stock, but regardless of the age you should be able to update the firmware to the latest version just fine.

    Have you tried to flash with both "NRF Toolbox" and "NRF Connect"?

    Please can you try:

    • Redownload the Puck.js firmware from https://www.espruino.com/Download#puckjs¬≠ in case it got corrupted somehow (also ensure it is the Puck.js one, and not Pixl.js or something else)
    • Using "NRF Connect" app and connecting to 'DfuTarg' (which appears when the green LED is on)
    • Ensuring you're not paired/bonded (you can do this from the '...' in the top right of the window)
    • Clicking the 'DFU' icon that appears in the top right when connected and updating firmware from there
    • Making sure you keep the app in the foreground and your phone doesn't go to sleep during the firmware update

    Also - does the issue happen on both Puck.js devices, or just one?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

Puck.js firmware update

Posted by Avatar for user109289 @user109289

Actions