App can't find board

Posted on
  • We have a MDBT42Q module built into a PCB that controls some LEDs. After uploading our firmware on 8 boards then connecting them to our app successfully, I have a board that our app cannot locate. All signs are showing a successful upload, and the IDE locates and pairs to the board no problem, so I can't figure out why this one board can't be discovered by our app.

    Any ideas?


  • Can we discuss this on the other post you made 20 mins earlier? I think it's basically the same issue?­332237/#comment14676323

  • Of course!

    To clarify - this board pairs successfully to the IDE and the code is successfully uploaded. But when I then try to pair our iOS app to the board, the app can't find it over bluetooth. As I mentioned, every other board works fine, so it's not a problem with our app.

    Happy to merge this with the other issue if it makes sense.

  • Just to be sure - you have one board that you're having connection issues with? Or you have two boards that have issues - one that you can't connect to your app, and one that you can't connect to with the IDE?

    Have you tried just disabling bluetooth on your iOS device and re-enabling it? iOS has some really messed up Bluetooth Cacheing behaviour

  • That's correct. This is a separate board.

    I have tried that and figured it must be an iPad issue. So I've tried several things around its settings with no luck. Every other board is located and connects great, and this one doesn't even show up as a device to connect with.

  • Can you run 'nRF Connect' on your iPad and also on an Android device if you have one, and see if that detects it?

    I guess it might depend how you filter out the device in your app. If it's via the UART service then the service is usually advertised in a 'Scan Response' packet, not the main one and can be a bit tricky. You'd be better off filtering based on the name.

  • Very strange - nRF Connect found the device and I connected to it. So then I went back to our app and the device was discovered. However once I connected to it I wasn't able to control the LEDs. I'll keep investigating as it seems likely to fall outside of the Espruino box :)

  • It could well be something related to scanning based on the 'Scan Response' - as I understand it, it might only be transmitted to paired devices - so if you're not paired then you don't get it and can't find the device.

    But yeah, more likely app related. But if you find out what the problem is I'd really appreciate it if you could l

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

App can't find board

Posted by Avatar for Tywilliams44 @Tywilliams44