Corrupted flash on Pixl

Posted on
  • I managed to corrupt the flash on my Pixl by pulling the power during a save (got too careless/impatient). I've managed to connect with NRF Toolbox and update the firmware, so DFU works fine. The Pixl boots and shows the Pixl.js v2.01 screen with the MAC and then nothing. The device is not advertised after booting.

    Is there any way to wipe the flash or otherwise recover the situation?

  • You should be able to just long-press BTN1 while booting (hold it right through the bootloader, and through the self test even when it tells you to remove your finger). That'll boot without loading saved code and should clear any code out of flash - you can always connect at that point and do require("Storage").eraseAll() to make absolutely sure everything is gone though.

    Espruino won't touch the flash memory that contains the interpreter itself (unless you explicitly enable that functionality) so if this happens again you should always be able to recover using the BTN1 trick.

  • Great, that worked. I had tried holding BTN1 for > 10 seconds (read it somewhere on the site) but got nothing.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Corrupted flash on Pixl

Posted by Avatar for cefitzger @cefitzger