Can pair puck in WIndows but not Chrome

Posted on
of 2
/ 2
  • I updated my new puck via Andriod to 2.00. I then quickly paired it with Windows 10 just fine. Now I'm trying to use the IDE In Chrome 71 and Chrome says it can't find my BLE device. I removed it from Windows just to be safe and it still didn't show up. I could re-pair it with Windows.

    Note that the puck is shining bright green.

    How can I quickly debug this?

  • I also tried the native IDE but it seems to have glommed onto the only serial port is found and I can't seem to figure out how to get it to disconnect.

    Good news is that my PixlJS "just worked" ... attached and the IDE downloaded.

  • Pull Puck's power plug - battery out for some time - that may help to let it loose its mind.

  • With the Pixl I had no problem connecting to both Windows and Chrome. Seems to be more of a protocol program.

    I also notice that the Windows IDE seems to assume that any serious port must be the device but there isn't a serial port in the Windows device manager -- shouldn't it be using the Bluetooth native interface? I ran into a similar issue try ing to use Visual Studio Code.

  • As noted, the Web IDE works fine and connects to the pixl but not the puck. The Windows IDE just gloms onto the first serial port it finds.

    So I did try

      <script src=""></­script>
      <button onclick="Puck.write('LED1.set();\n');">O­n!</button>
      <button onclick="Puck.write('LED1.reset();\n');"­>Off!</button>

    (served from localhost) and it has the same problem -- finding the pixl but not the puck

    as an FYI the puck is glowing green now that I replaced the battery. It appears to stay on and run down the battery.

  • Was the Puck working with a previous version before flash to 2v0?

    If so, try to re-flash to a previous version.

    Glowing always green is suspicious.

  • ref­+BLE#when-i-insert-the-battery-the-green­-light-comes-on

    Inadvertently holding down the button while inserting battery?

  • Tried rebooting but no matter what I do I never see the red LED -- and once the green is on it just stays on. Things went smoothly when I did the flash to 2.00.

  • What was the state of both LEDs after flash, when 'Things went smoothly'?

    We're you successful in uploading any user code?

    Back to #7 above, was Puck working before flash?

    re 'I never see the Red LED'

    Could the button be stuck down?

  • When I got the pick and first flashed it everything seemed to work right and go smoothly. Not sure if the green light came on before my initial attempt to pair with the IDE (Chrome) but even then it paired with Windows desktop.

    What's also strange is that the PIXL is readily pairable in Chrome but neither is showing up in the nRF Toolbox

  • As @allObjects indicated in #3 what is the state of the LEDs after the battery is pulled and re-inserted? If green, check button.

  • When I pull the battery and reinsert it all is dark. It goes green when I press the button whether immediately or later.

  • Have you u/l code and typed save()?

  • The only code I did was a slight modification on the sample app for the Pixl. NEver get far enough to have code for the puck.

  • Sat 2019.01.05

    If I accept that the responses are accurate for the questions I posed, it's back to step #7 for a re-flash.

    ref #2 'the native IDE but it seems to have glommed onto the only serial port'

    For the Native IDE, if BlueTooth is active, upon selecting the connection icon, the popup dialog should show a list of identified BLE devices, such as: 'Select A Port' ca:97:fc:73:b1:32 Puck.js b132 Are you seeing the distinctive BLE icon and a description as above?

    If the online version is used, the popup dialog will show 'Web Bluetooth Bluetooth Low Energy' along with the distinctive BT icon, and when clicked will launch a modal dialog that allows the pairing of the devices. Are you seeing this sequence?

    See Heading 'Once Web Bluetooth is set up'

    If either of the above worked as described, what was the output viewed in the left hand console pane of the IDE?

    It is interesting to note that my BT compatible laptop (three yr old) running Win10 would never connect reliably. I then purchased a current BLE401 USB dongle which resolved my issues. . . . .

  • Native just shows the pixl and my serial port. I removed the battery and replaced it and then hit the button in 3 seconds but it still went green immediately. The web version doesn't even show a serial port. That serial port is associated with another device so is moot.

    Since DFUTag isn't showing on my Android, and I don't see the red LED no matter what I do I think I'm going to have to assume the puck is no longer viable.

    1 Attachment

    • native.png
  • Before jumping to conclusions, have the following tests been performed?

    'and then hit the button in 3 seconds'

    Are you able to perform a 'Hard Reset' holding the button more than the three seconds that was indicated? Under heading 'Hard Reset'

    'but keep the button held for around 10 seconds'

    1) Press and hold the button for ten seconds while inserting the battery.

    Describe the sequence of LED output.

    2) Remove the battery. Insert without pressing the button.

    Describe the sequence of LED output.

    'The web version doesn't even show a serial port'

    Please re-read topic beneath Heading 'Once Web Bluetooth is set up' found in second link in #16 previously posted.

  • Since @BobFrankston did the 3-second press already - @Robin, your posts obviously crossed on the network - it could be that the switch is not working for what ever reason. It is very rare that hardware - and software - from @Gordon has a break down, but it is possible.

    I do not know what the green led continuously on means.

  • As much as I like the blame the hardware I realize that it's usually the user. But in this case, I'm out of ideas. And have to move on ...

  • This time I got the Bluelight and am installing 1.99. Persistence ... stay tuned to 2.4Ghz.

  • And now, with 1.99, the app is working. Will upgrade to 2.x when it's safe again ...

  • I'm glad for you @BobFrankston that you got it going again with the input of @Robin... Going back to doc always helps... either to confirm the issue or get thru it.

  • I thought I'd followed the doc each time but ... well, it works for now and may true 2.xx at some point. I even got the IR sort of working and discovered I can turn on the date. Big thing I want to do is get Visual Studio Code working but getting errors trying to use the espruino module. But that's for another day.

  • Sun 2019.01.06

    I'm glad you stuck it out @BobFrankston and have proven the hardware is sound. I realize there is a ton of documentation that needs to be grasped, but it appears you have now mastered that. Was there an item that could have been improved?

    I'm curious, . . . . what was the key that unlocked the perplexing mystery to obtaining a working device?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Can pair puck in WIndows but not Chrome

Posted by Avatar for BobFrankston @BobFrankston