• Hi

    I have just upgraded firmware of Espruino Wifi 1.1 using Espruino Web IDE v0.70.6.
    Before the upgrade it was working fine. After the red LED stays on and I can not see serial port any more.
    Any clue what is wrong please? How can I recover the Espruino Wifi?
    Thank you

  • Hello @Grzegorz_

    'Before the upgrade it was working fine'

    For how long was it working?

    What version of Espruino were you at, and what version were you attempting to flash (2v0 ? ) ?

    Have you tried powering down the WiFi then reconnecting? Have you tried closing the IDE and relaunching?

    Worst case, have you attempted to re-flash back to an older version from:


    or 'Find a binary'


    and what were the results of performing that task?

    May I ask what PC O/S? Mac/Win10/Linux

    What baud rate is the serial port set to?   IDE >> Settings >> Communications

    Is there any additional detail listed in the console output?    IDE >> Settings >> Console towards the end of the listing

  • Hi,

    Is it possible you uploaded the wrong firmware? That's usually the culprit - especially if you had been using another Espruino board before the IDE may have got confused about the image it should upload.

    Otherwise it's possible the connection failed halfway and the image only got part flashed.

    You should be able to re-enter the bootloader the normal way and try flashing again - and hopefully that'll work for you.

    @Robin, it's USB so baud rate has no effect I'm afraid.

  • Hi
    Thank you for prompt answers, the Espruino Wifi was working fine for weeks, I don't remember exact firmware version before update unfortunately, something like 1.6 I think. The new version I believe is 2V0, as it was done via Espruino Web IDE with Normal Firmware Update. I use MacOS High Sierra.
    I have re-flashed the unit with Advanced Firmware Update with espruino_2v00_wifi.bin and it works fine now.
    Thank you so much for your support

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Espruino WiFi, red led lit on and no serial port after firmware upgrade

Posted by Avatar for Grzegorz_ @Grzegorz_