Having trouble building a working Puck.js image

Posted on
  • Building on an Ubuntu BB virtual machine, I use the following commands:

    . scripts/provision.sh PUCKJS

    And then send the file to my Android phone and use NRF toolkit to DFU it to the puck, followed by a hard reset.
    I can connect with the web IDE over bluetooth, but the puck gets hot Wondering if I've enabled a tight loop somewhere.
    Using git revision 6b2b4a3385966b4190205b438f531411dfe253cb­

    1 Attachment

  • but the puck gets hot

    Are you sure about that? And you're just powering it from a CR2032, with nothing else connected?

    When the processor's really working hard the whole thing usually only draws around 4mA (the radio add 10 or so) - but even so that's really not enough to make the device hot.

  • Er, I'm powering it from a 3.3v supply off USB, am I slowly letting out the magic smoke?

  • I'll stick a 20Ω resistor between 3V3 and the Puck, to simulate the internal resistance of a CR2032

  • Fri 2018.09.28

    Hello @rmd6502, it appears we may be dealing with two issues, so let's remove a bit of confusion.

    re: 'I'm powering it from a 3.3v supply off USB'

    I'm taking this literally here, but don't wan't to guess. Is there a separate power supply or battery pack being fed by the USB port? (e.g. step down converter)


    "As with earlier versions of USB, USB 3.0 provides power at 5 volts nominal."

    If not, that magic smoke you mentioned might not have any magic in it at all. If this is the case, would you mind posting an image of your wiring so we may take a look. Frayed wire end, solder blob, mis-placed wire, etc. I agree with @Gordon that there shouldn't be any heat felt whatsoever.

    Have you tried just a CR2032 and compared heat dissipation with that?

    Let's resolve the power supply part first, then others may be able to help with the firmware part.

  • @Robin lol yeah, it's a xbee serial adapter with a linear regulator built in, but you're right, I should double check that the 3.3v switch is actually delivering 3.3v and not 5 - I should have thought of that immediately. I'll try powering it off a coin cell also, I bet the heat problem will completely go away.

  • Well, !@#$% me. Vcc and all the 3V3 pins read 5.216V regardless of which position the voltage switch is set to. Likely the regulator is defective or something. Glad the puck still has its magic smoke!

  • Thanks for the update - that's good to know!

    I could be wrong here, but VCC can mean 3.3v or 5v (or a bunch of other stuff) - it's just the voltage the system runs at. But yeah, if the 3.3v wires have 5v on them, that's extremely scary!

    Honestly, I'm pretty impressed the Puck took that - I guess maybe the 5v regulator isn't that powerful so maybe with the increased power draw the voltage dropped to something less destructive!

  • Yeah, in this case it was supposed to mean 3.3v - it's an old XBee dongle from Seeed, apparently no longer supported. I'm guessing since the regulator was fried its internal resistance was high so the voltage dropped to something more than 3v and less than 5 - not going to hook it back up to check :-)
    Anyway, I'll close this thread since the problem is solved, and move over to Projects where I'll talk about the modified SPI driver I'm working on for Sparkfun's flexible OLED display!


Having trouble building a working Puck.js image

Posted by Avatar for rmd6502 @rmd6502