• I have a problem to connect to Puck.js after updating the firmware to 1.99. I tried to connect to the bluetooth device via bluetooth device manager on windows. But I always get an error that I should try it again. When I try to connect to beacon using the NRF connect App it works well.

    Do you have any idea? Before the update it worked without any problem.

  • Wed 2018.08.22

    Have you attempted to flash using a previous version? If so, did full functionality return?

    Try this first though:

    Was the Puck connected to another BT device? I believe that step of unpairing has to occur, before re-establishing BT after update. Searching for documentation. . . .


    Ahhh . . . Here it is:



    see: 'Troubleshooting' find:


    beneath the heading: 'I can't see my device any more'

    Espruino BLE devices can only accept one incoming connection at a time. When a device is connected to it, it stops advertising and so cannot be connected to until the first device disconnects.

  • Got it by doing a reset after downgrading the firmware and then upgrading it again.

  • Glad it's sorted - did you do a reset after upgrading by long-pressing the button when powering it on? That can sometimes help.

  • Yes, I did. But I did that already before downgrading and it did not work. The only solution was to downgrading to V1.95, doing a reset, upgrading to V1.99 and doing a reset again. Might be a problem that I upgraded from V1.88.

  • Thanks Mobitech. works great.
    From 1.88 to 2.03 is not possible. You need to first upgrade to 1.95 and then 2.03.

  • From 1.88 to 2.03 is not possible. You need to first upgrade to 1.95 and then 2.03.

    ...surprise to me... I see nothing mentioned in http://www.espruino.com/Puck.js#firmware­-updates

    So it must be that before attempting to update directly to 2.03 from 1.88, some application residuals have been left over... Did you do a reset(1) before attempting? But I'm almost certain that not even that is needed.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Cannot connect to Puck.js after updating Firmware to v1.99 with Windows 10

Posted by Avatar for MobiTech @MobiTech