Espruino Native IDE doesn't launch properly.

Posted on
  • Hey, I have a system here that doesn't seem to work with the Espruino IDE. The application opens, I see a black screen. The contents of somehow interactable though. There's also and odd static sound that plays. It's a Windows 10 machine. Works fine on my main computer though.

    Any ideas? Logs I can check? Already turned off hardware acceleration in Chrome just in case.

  • Are you using the chrome extenstion?

    You could try the native windows installer version.

  • I am using the Desktop IDE.

  • Wow, that's really strange - especially the sound! Honestly I'm not sure what to suggest.

    By Desktop IDE you mean the native one - not the Chrome Web Store IDE? That one doesn't use Chrome directly (it installs its own copy, called NW.js) - but you could try adding --disable-gpu --force-cpu-draw to the command-line of the shortcut and see if that helps.

  • There is a sound tab in settings, did you switch this on by accident ?

  • Desktop IDE. Finally tried this, and it still didn't show up with anything.

  • Mon 2018.08.20

    @tako, are you able to access the Settings button just below the Close 'X' in the upper right corner of the IDE, or is the entire IDE black as you indicate in #1 above?

    'I see a black screen'

    If successful, what version is displayed: Settings >> About

    or, . . . what is the file name and date that the install was from. Maybe in the downloads folder. Something like:


  • I'm not able to access anything. The entire screen is black, but I can see a blue outline near the top.
    Last version I tried was: espruino_ide_win64_0v69.0.exe

  • That appears to be the latest release.

    As this is Win10, have you tried a full un-install and attempted a re-install?

    Settings >> Apps >> Apps and Features :: Un-install

    Might provide a clue by going through that process.

    This might not be the version you are after, but does the online WebIDE become functional on launch?

  • Yes, I've tried an uninstall and reinstall. Trust me, I've tried all troubleshooting that I can think of - I'm a computer technician, so I've pretty much tried everything before asking for help.

    The Web IDE "opens", but I can't use it, as non-Canary Chrome does not support Web BLE yet.

  • and this is a different Win10 PC than that used in forum post F13-F24 HID keys then?

    I'm puzzled, you were communicating with a Puck using a Win10 PC there, so presumably was the native IDE for BLE which should be the same as the one installed from the file indicated in #8 above?

    'Trust me, I've tried all troubleshooting that I can think of'

    Then I would list the PC mfg, processor/board perhaps along with the version of Win10 for Gordon's reference.

  • Right. I program, commit, push, deploy, etc on my computer at my desk.

    Usually, I'll connect the puck to my workstation, upload new code, disconnect it from my workstation and reconnect it on our "production computer". My workstation is 100% functional and has no issues with the IDE.

    The production computer is the one having issues - it's able to connect via BLE, the IDE just doesn't open completely. I need the production computer to be functional, so other non-technical users can simply open the IDE, to troubleshoot and redeploy the code as-needed.

  • It is midnight where Gordon resides.

    I'm not aware of the ability to retrieve older versions of the IDE from the site.

    Just the cutting edge install­DE

  • I retested the two flags (--disable-gpu --force-cpu-draw) and they worked this time. Not sure what went wrong the first time. So, consider this resolved.

    Though, maybe NW.js needs an update?­2

  • Wow, interesting - thanks for the link! Glad it's sorted with those flags - I'll update NW.js in the next week or two (it's a bit painful as some of the native modules need recompiling).

  • I'm not sure if nwjs has actually fixed the issue on their end or not. Seeing a lot of different reports over the years for similar issues.

    If it's a hassle to update, I would say don't worry about it. The flags are a perfectly fine solution for me.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Espruino Native IDE doesn't launch properly.

Posted by Avatar for tako @tako