Unable to flash Pico

Posted on
  • Tried to update Pico from v96 to v97 thru IDE (able to Flash Espruino, WiFi) but receive "Connection Failed" with the Pico. I was previously able too upgrade to v96 but something has happened in between 96 and 97. Anybody experienced this also? Used the same process as always which worked as expected.

  • If you flashed a Original or WiFi beforehand and then immediately flashed a Pico, the IDE may have assumed you were still using one of them and updated the wrong firmware?

    Perhaps you could try restarting the IDE and flashing - then it should realise it doesn't know what the board is and ask you which board you want to update?

  • ...in other words, a disconnect and reconnect aren't sufficient to detect a device change, or replace components loaded specifically for a device when that device first connected.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Unable to flash Pico

Posted by Avatar for BillHoy @BillHoy