ESP32 stability

Posted on
  • Hi,

    I might be doing something wrong with my olimex esp32-evb, and I am posting what I see on the left window.

    Some core dumps after onInit() and unexpected chars are seen.

    Got it working once by the log file end... with telnet connection.


    1 Attachment

  • Without seeing what code you are uploading and what you are trying to do it would all be guess work.

    What you are seeing is a core dump - something is causing the board to panic.

  • The code can be seen in the attached file also.. and I sent you a PM.

  • I'm not sure what is so secret about your code that you don't want to post it?

    You can * out the passwords.

    You have code that is using wifi.connect - however you are using wifi.save as well....
    The wifi.save saves the current connection and on next restart -automatically connects. This is useful for telnet to the device..

    So you don't need wifi.save in your main code.
    The way it it working at the moment is

    • restart device
    • it auto connects to the wifi
    • then you connect to wifi when the connection is already done.
      Perhaps this is why the wifi.disconnect case works.

  • Yes, it looks like it does not want to have a running wifi on startup. Has been running fine since I removed it.

    Thanks.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

ESP32 stability

Posted by Avatar for user87761 @user87761

Actions