• Hi,
    I bought a pico a while back and used it for a bit and then decided to to run micropython on it as a comparison. I didn't really use it that much with micropython so decided to swap it back to running espruino. Initially i tried to just re-flash it using the web IDE but it would not connect to the board (It did detect it though). I then tried to re-flash it using dfu-util (i'm running linux and used a pencil to short boot0/btn) as i had done to put micropython on it in the first place and this seemed to work (got no errors). I then got rid of the graphite but since then it has refused to power up and now nothing happens - no lights at all. The web IDE indicates no usb port (/dev/ttyACM0) only internal serial and both lsusb and dmesg show nothing. Could this be caused by not clearing out the graphite properly (i thought i had) or have i bricked it?

    Any help is much appreciated.

    Cheers.

  • Hi,

    dfu-util should work - but you'd have to use the right firmware file. Did you use the one from http://www.espruino.com/Download or one of the 'cutting edge' travis ones?

    The travis builds don't actually contain a bootloader (the file is just padded with 0s), so if you'd uploaded one of them it wouldn't have worked - could that be the issue?

    Also with the graphite: all it does is make BTN0 switch to the chip's DFU bootloader rather than Espruino's - so if you leave the graphite on then Espruino should still work. The only issue will be that you'll be unable to enter the bootloader that the Web IDE can use (the one that flashes the LEDs).

    Hope that helps!

  • HI Gordon,
    Thanks for the reply.

    Yeah you were right , i was using one of the Travis ones, when i re-did it with the correct file and eventually got it into DFU mode it uploaded fine and i now have the PICO running again - thanks for that.

    One quick question: you have a kindle version of the making-things-smart for on-line purchase, is there also a straight PDF version for on-line purchase?

    Cheers.

  • I'm afraid I'm not sure about the PDF. It was available as a PDF in the Humble Bundle Make did a while back (it doesn't seem to be available now), and it might be available via PDF on Safari? http://shop.oreilly.com/product/06369200­31246.do

    I'm not sure Amazon do it though. If you've actually bought the book then I could send you the PDF that I have here?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

issues when re-flashing pico to latest espruino after running micropython on it.

Posted by Avatar for user82036 @user82036

Actions