• Mon 2017.07.31

    I have installed the native Espruino IDE v65.9 on Windows 10. Have successfully paired. I am able to connect via Bluetooth and am able to see the green connected verification modeless popup dialog indicating the MAC address over the lower right hand corner.

    The left hand panel shows "Connected >" and the flashing caret. But the Espruino banner never shows. Clicking in the left panel then immediately typing never updates, always a black screen, but it can be verified from Settings>>Console that typed characters are being recognized.

    Can send code snippets from the right hand side along with Blocky examples, but the left hand panel never updates. LEDs flash on Puck so code is executing there.

    Have tested Com port mode and am able to connect to a Pico. Left hand panel accessible.

    Is this related to the version of Puck firmware or is the native Espruino IDE under Bluetooth suspect?

  • Are you using the original Puck.js firmware? Updating may help you, but I don't remember seeing this problem before... Have you just tried powering the Puck itself off and back on? If it's old firmware I guess it could have go itself into an off state.

  • Tue 2017.08.01

    @Gordon, Yes, the original Puck.js firmware 1v88

    However not able to update http://forum.espruino.com/conversations/­308440/#comment13773153
    as I was waiting to see if there is the possibility.

    Tried all ideas of re-powering, re-connect, different button press duration combinations, re-launch and reboot, etc. Unfortunately, don't have a second Puck on hand at the moment.

    Incidentally, I had read at least one occurrence of this roughly four months ago, but couldn't locate the post, and search was unsuccessful.

  • Are there any errors shown in the IDE's console?

    I'm not really sure why this would be happening, but if you could find a way to update the firmware then that would be a really good start I think.

  • Tue 2017.08.01

    @Gordon, there doesn't appear to be any errors, just no output other than 'Connected >' in left pane:

    From a fresh instance Native IDE

    We have chrome.serial - not using 'serialport' module
    'noble' module couldn't be loaded, no node.js Bluetooth Low Energy  Error: LIBUSB_ERROR_NOT_SUPPORTED
    Disable Web Bluetooth as we have Winnus instead
    serial_audio: Audio Sample rate : 48000
    serial_audio: Audio Serial Baud 9600 Bit time 5
    Web Bluetooth available, but Windows Web Bluetooth is broken in <=56 - not using it
    GET chrome.storage.sync = {"AUTO_SAVE_CODE":true,"BAUD_RATE":"9600­","BLOCKLY_EXTENSIONS":"|bluetooth|robot­|","BLOCKLY_LANGUAGE":"en","BLOCKLY_TO_J­S":false,"BOARD_JSON_URL":"http://www.es­pruino.com/json","CODE":"var  on = false;\n\n//if(false){\nsetInterval(func­tion() {\n  on = !on;\n//  LED1.write(on);\n//  LED1.write(false);\n  LED2.write(on);\n  LED3.write(!on);\n}, 1500);\n//}\nvar c = function(){ clearInterval(); };\n\nvar f = function(){ LED1.write(0); LED2.write(0); LED3.write(0); };\n","COMPILATION":true,"COMPILATION_UR­L":"http://www.espruino.com:32766","ENAB­LE_Testing":false,"ENV_ON_CONNECT":true,­"FONT_SIZE":12,"MINIFICATION_DeadCode":t­rue,"MINIFICATION_LEVEL":"","MINIFICATIO­N_Literal":true,"MINIFICATION_Mangle":tr­ue,"MINIFICATION_Unreachable":true,"MINI­FICATION_Unused":true,"MODULE_AS_FUNCTIO­N":false,"MODULE_EXTENSIONS":".min.js|.j­s","MODULE_MINIFICATION_LEVEL":"ESPRIMA"­,"MODULE_URL":"http://www.espruino.com/m­odules","NPM_MODULES":false,"RESET_BEFOR­E_SEND":true,"SAVE_ON_SEND":0,"SERIAL_AU­DIO":"0","SERIAL_TCPIP":"","SERIAL_THROT­TLE_SEND":false,"SET_TIME_ON_WRITE":fals­e,"SHOW_CODE_LINK_ICON":false,"SHOW_WEBC­AM_ICON":0,"STORE_LINE_NUMBERS":true,"So­und_Error":"","Sound_Info":"","Sound_Suc­cess":"","Sound_Warning":"","Speak_Error­":false,"Speak_Info":false,"Speak_Succes­s":false,"Speak_Warning":false,"UI_MODE"­:"Normal"}
    Initialising SettingsConsole
    Initialising Utils
    Initialising Config
    Initialising Notifications
    Initialising Status
    Initialising App
    Initialising File
    Initialising Code
    Initialising Serial
      - Initialising Serial Chrome Serial
      - Initialising Serial Chrome Socket
      - Initialising Serial Windows NUS BLE
      - Initialising Serial Audio
    Initialising Terminal
    Initialising CodeWriter
    Initialising Modules
    Initialising Env
    Initialising Flasher
    Initialising EditorBlockly
    Initialising EditorJavaScript
    Initialising Send
    Initialising MenuPortSelector
    Initialising MenuSettings
    Initialising MenuFlasher
    Initialising SettingsAbout
    Initialising SettingsFlasher
    Initialising BoardJSON
    Initialising VersionChecker
    Initialising Compiler
    Initialising Assembler
    Initialising GetGitHub
    Initialising NPMModules
    Initialising ExamplePlugin
    Initialising Unicode
    Initialising SaveOnSend
    Initialising Minify
    Initialising Tutorial
    Initialising Webcam
    Initialising FontSize
    Initialising UiMode
    Initialising URLHandler
    Initialising CodeLink
    Initialising Project
    Initialising Testing
    Initialising Notification_Sound
    Initialising Tern
    Initialising Debugger
    Initialising Tour
    Initialising SettingsProfile
    Initialising HelpLinks
    Loaded code from storage.
    >>> Connecting...
    Set Slow Write = true
    Connected [object Object]
    Found a prompt... great!
    >>> Sending...
    ---> "\u0010console.log(\"<\",\"<<\",JSON.str­ingify(process.env),\">>\",\">\")\n"
    BT> Sending "\u0010console.log(\"<"
    BT> Sending "\",\"<<\",JSON.str"
    BT> Sending "ingify(process."
    BT> Sending "env),\">>\",\">\")\n"
    >>> Sent
    Got "< << {\"VERSION\":\"1v88\",\"BUILD_DATE\":\"N­ov 10 2016\",\"BUILD_TIME\":\"11:53:15\",\"GIT­_COMMIT\":\"b041fd452cfe48f488fcab77c602­eb95a1cba528\",\"BOARD\":\"PUCKJS\",\"CH­IP\":\"NRF52832\",\"CHIP_FAMILY\":\"NRF5­2\",\"FLASH\":524288,\"RAM\":65536,\"SER­IAL\":\"3e9fc4de-e573d199\",\"CONSOLE\":­\"Bluetooth\"} >> >\r\n>"
    Loading http://www.espruino.com/json/PUCKJS.json­
    Device found (connectionId=undefined)
    [success] Connected to port ca:97:fc:73:b1:32
    >>> Connected to port ca:97:fc:73:b1:32
    Board JSON loaded
    Set Slow Write = true
    FIRMWARE: Current 1v88, Available 1v93
    BT> Sending "3"
    BT> Sending "+"
    BT> Sending "4"
    BT> Sending "\r"
    BT> Sending "a"
    BT> Sending "s"
    BT> Sending "d"
    BT> Sending "f"
    BT> Sending "g"
    BT> Sending "\r"

    Could port speed be an issue? I've tried 9600 default and boosted up to 115200 with no luck.

    EDIT: Don't think so as it appears I am able to send code from right-hand pane. Keyboard presses don't seem to go to left-pane even after clicking in LH pane.

    Will try again when I have a new Puck and the ability to flash via a smart phone.

  • No, port speed only applies to USB-TTL adaptors - even on devices like the Pico it's ignored.

    New firmware would help, but it'd also be good if you got a chance to try a different computer. I guess it's possible there's something a bit iffy with your Bluetooth adaptor drivers - it's still relatively early days for Bluetooth LE on PCs

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Native Espruino IDE left pane doesn't update using Puck on Windows 10

Posted by Avatar for Robin @Robin