USB HID not working in Windows 10?

Posted on
  • I have sent the following code to the espruino pico and saved:

    var kb = require("USBKeyboard");
    setWatch(function() {
      kb.setModifiers(kb.MODIFY.SHIFT, function() {
        kb.type("HELLO WORLD", function() {
          kb.setModifiers(0, function() {
    }, BTN, {debounce:100,repeat:true, edge:"rising"});

    The LED2.toggle() works perfectly after unplugging and re-plugging but nothing happens when I press the button when I'm expecting "HELLO WORLD". I am fairly new so I apologise if I've simply missed something obvious

  • Hi - have you typed save() on the left-hand side? Otherwise the code you wrote will be lost when the device is unplugged - which might explain the lack of the LED toggling?

    Also, are you using up to date firmware? This only started working properly in Windows in around version 1v92 I think.

  • Thank you for responding so quickly! My apologies, I didn't explain very clearly. The LED works perfectly all the time. I did use save(). It's just the "HELLO WORLD" part that does nothing, even after unplugging and replugging the pico.

    The Firmware is 1v93

  • What OS are you using? I just tried this on Mac OS and Linux and it's working for me...

  • Just tried this code with Win7. LED is OK but no keyboard input at all.
    It seems that the Pico remains enumerated as a virtual COM port only

  • Just tried on Windows 7 and I have the same. However it works great on Windows 10

  • Windows 10 is what I was using. I have switched to ubuntu and now it now works as expected. It's no biggie for me for now that it doesn't seem to like windows 10. Thanks for the help!

  • Ok, great! I'd be interested to know why it didn't work in W10 though - it appears to work fine here so I'm not sure what the difference would be.

  • I'll have a look into it a bit more and I'll post here if I discover anything

  • I'm having the same problem .
    I have 2 notebooks. one intel the other AMD
    In the amd the keyboard code just doesnt work.
    In order to use and program the pico in the AMDI had to install one of the drivers because the windows could not recognize it by him self.

  • Fri 2020.03.27

    Hi @user110807 were you aware this is opening a really old thread? Many changes and resolutions since three years ago.

    Lets start with process.env please post.

    To confirm, this is with just the Pico and not Bangle?

  • Pico 1v3
    Can you show me the right posting directions? are there any new posts on the subject?

  • process.env
    Connected to COM7

    VERSION: "2v04",
    GIT_COMMIT: "3956264e",
    BOARD: "PICO_R1_3",
    FLASH: 393216, RAM: 98304,
    SERIAL: "5e004b00-13513430-36363435",
    MODULES: "Flash,Storage,hea" ... "v,crypto,neopixel",
    EXPTR: 536871168 }

    1 Attachment

    • process.env.jpg
  • Fri 2020.03.27

    'show me the right posting directions'

    There is a nicely written post pinned to the top of the 'Tuorials' forum that contains nine bulleted items. Most follow that.­/

    Thank you @user110807 for the environment, which confirms latest flashed version. I only ask for the board type confirmation as we recently got clobbered with an HID using Bangle issue, and wanted to make sure we have a different one here, and it appears we do.

    Were you working from this tutorial, as one wasn't specified, and if so, what is/isn't happening? Able to post some output to provide an idea on how to move forward? Where in the tutorial did progress cease? Are you just attempting to communicate with the Pico or are you after the HID tasks?

  • Thanks,
    I was folowing this exact tutorial
    but I was not getting any result. I changed the code a bit to see if it was actualy doing something.
    The final code is the one on the image I sent above.
    The leds were turning on but no text was sent to the computer.
    First some background:
    I am using a Sony vayo with AMD processor.
    The First time I tried to use the pico on it the correct driver was not installed.
    In the link­
    I saw the message Non-Windows XP users download version 1.4.0 drivers. ... dpinst_amd64.exe for 64 bit systems.
    As my computer was an AMD I tried this driver an it solved the problem. The pico was recognized and I could use the IDE.
    I tried to use the code of the Example "USB and USB HID Keyboard" without success.
    I searched the web and I finaly came to this coments in the forum where Gordon said that the code was working on his windows 10 but user user79809 said that it was not working on his.
    So I decided to try the pico on another windows 10 computer this time an Intel one.
    And voila... it works as a charm.
    So I have a pico with the keyboard "hello world" code that works on the windows 10 intel but does not on the AMD.
    I believe it must be a Driver issue. (dpinst_amd64.)
    PS. In the AMd the leds work but no keyboard character is sent to the computer.

  • Wow, that's really odd. If you look at 'Device Manager' do you see anything? I imagine there may be a 'USB Keyboard' device with a warning next to it and some message?

  • nothing apears on the AMD .
    On the INTEL computer apears keyboard HID.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

USB HID not working in Windows 10?

Posted by Avatar for user79809 @user79809