What's the problem with my puck.js

Posted on
  • Hello.

    I cannot make a pair with my puck.js suddenly.

    When I try to pair, my puck lights up all leds for 1 sencond after then red led flashes once shortly.

    I tried all things I can do. (Reset, rewrite all kind of firmwares, but the same.)

    Same with my iPhone 6.

    How can I fix it?

    Please help me.

  • Hi,

    You should be able to get around this by flashing firmware 1v91 and running some commands, however I didn't realise this was still happening.

    Hang on, and in an hour or so I'll post again and I should have a new firmware that will fix this for you.

  • Ok, if you try uploading the puck.js firmware zip file from here: http://www.espruino.com/binaries/travis/­34f43c4987a0067d2f9510b64ae812ed75f59f4a­/

    And then reboot with the button held down until all 3 LEDs light and then release, the green LED should flash (showing self test was fine) and you should be able to connect properly from then on.

  • It's working!!
    I upload the new firmware and reset. Everything is fine.
    Thank you so much.

  • No problem, that'd great!

    Out of interest, do you have any idea what could have started the issue? Did you connect to lots of different computers, or play around with the flash memory module? If I have some idea what causes it I might be able to stop it happening in the future, but I haven't been able to reproduce it here.

  • Not to lots of different computers, but to same computer. I repeated remove pairing and repairing the puck to PC. while doing this, puck went wrong.
    I hope this helps you.
    Thank you.

  • My Puck.js has unfortunately gone into the same state.

    I unboxed the device yesterday and more or less immediately updated the firmware (1v93). Then I spent a few hours just exploring it. Tested the (desktop) IDE a bit. Advertised a service/characteristic and tried to get that information with a small script on my Raspberry Pi Zero W. That involved a lot of trial and error, with repeated connections and requests for service/characteristic info.

    I don't remember exactly what happened, but out of the blue the script was no longer connecting / getting info as expected. After removing/inserting the battery, I could no longer connect from the Windows control panel. It just resulted in the LED behavior described in this thread.

    I got new firmware (1v93.162) from the link above and flashed it successfully. The problem still remains, though. At one point, Windows was suddenly able to connect. I saw that the IDE printed "app_timer_start error 8" over and over again really fast. After disconnecting, the LEDs started to flash again (the "all three, then red" sequence), now repeating every ~1-7 seconds.

    It's still possible to connect using nRF Connect and LightBlue. LEDs seem to go dark when connected, then the sequence may start again after disconnecting.

    Any ideas?

  • Now you've got the latest firmware (1v93.162), please can you reset Puck.js with the button held down? Just like you did for the bootloader, but leave it held down until all 3 LEDs light, then release it.

    After that the green LED should flash 5 times, and:

    • Any code you saved to flash won't be loaded
    • All pairing information will be deleted from Puck.js

    Hopefully at that point you'll be able to connect fine - and when you do type save() on the left-hand side of the IDE to overwrite any saved code with an empty state.

    Hope that fixes it for you! Most likely it was something that got saved onto Puck.js itself that was causing it problems.

  • Thanks, that got it working again! :)

    I had tried a similar procedure earlier, but then I held down the button until all 3 LEDs lighted AND the red one flashed. Releasing the button exactly when the 3 LEDs lighted worked immediately.

  • Great!

    The red LED flashing a few times isn't a big deal. Basically Puck.js runs a quick self-test. If you don't release the button quick enough then it thinks the button might be broken and flashes red to tell you - but it doesn't affect anything!

  • Happened to me as well after flashing from v1.88 to v1.95.

    1. Tried the boot test method - the green led flashes 5 times just fine, then Windows is able to connect, but the Espruido IDE acts very sluggish. I did manage to do save() once, in order to clear any saved code that might still be there.
    2. After that save() the device wont pair again (again - all lights flash and then just the red one).
    3. Tried flashing v1.95 twice.
    4. Tried flashing v1.93_162 from the link above. The device is still malfunctioning.

    Right now it seems bricked.

    EDIT
    Another reset after the v1.93_162 seems to have done the trick.
    Should I flash v1.95 again?

    EDIT 2
    Well - it's still bricked. Now I get "NRF ERROR 0x3 at ?:0" after pairing

    EDIT 3
    And now "app_timer_start erro". Yeah - that's not a typo.

  • Try installing 1v95, then long-press the button on boot... Like you did with the test method but just keep holding it. All 3 LEDs should come on, then you get 5 red flashes - and release a few seconds after it stops.

    That should totally clear out the flash memory (rather than just not loading it) and then allow you to connect properly again.

  • Hi Gordon - tried that method a few times prior to installing 93_162.

  • Flashed 95 again. Now I get the following upon connecting:

    Uncaught [object Object]
    at line 1 col 9
    console.log("<","<<",JSON.stringify(proc­ess.env),">>",">")

  • If you hit enter and ctrl-C a few times in the console, does anything happen?

    You're at least seeing there that there was some communication between the IDE and the Puck

  • Nothing happens. The IDE seems to be frozen.

  • And we're back to square 1 - puck lights all leds and then flashes red.

  • Is my device bricked?

  • I can sometimes pair once after doing the self test procedure, but I get the following error after connecting:
    NRF ERROR 0x3 at ?:0

    Also tried changing the battery.

  • I get the following error after connecting: NRF ERROR 0x3 at ?:0

    And that's with 1v95 on it?

    If you're ok with it, can you send it back and I'll send a replacement - as while I have some ideas for how it could be fixed, I'd like to figure out exactly what has gone wrong with yours so it doesn't happen to anyone else.

  • Please can you send me a personal message and I'll give you the postal address and return details?

  • Ok, just some other thoughts...

    As you seem to have it connecting better with 1v93, you could try using the advice in http://forum.espruino.com/conversations/­303637/ and see if that helps you at all.

    You could also see if you have more success trying this method of connecting: https://github.com/espruino/EspruinoHost­#usage

    It might be that on Windows the secure connection is causing problems. I recently (yesterday!) had someone with what appears to be similar connection problems with 1v95 on Windows, so I'm wondering if it's a windows update that broke something - I hadn't noticed similar reports before.

  • Tried the pageErase method and then flashing ti v95. Got the same results - all LEDs are flashing.
    Flashed v94 for the first time - got the same behaviour as v93: got a high connection ratio, sometimes connection/disconnection loop but managable.

    So it seems that something went wrong in v94 -> v95.

  • Thanks - I spent a while looking into this on Friday. It seems that 1v95 has a problem with connecting in Windows (which is I believe due to using a secure connection), whereas as you say 1v94 is much better. If you were to use
    the web bluetooth polyfill you might have some luck with 1v95, but I'd hold out until I manage to fix it.

    I haven't been able to narrow it down to any particular change - at some point the builds just started working intermittently - some are fine, some are broken. I've contacted Nordic about this as it seems to be something iffy with how their libraries get compiled - hopefully I'll hear back soon.

  • Please keep us updated. Thanks.
    Also - v94 is not 100% stable with regards to connection.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

What's the problem with my puck.js

Posted by Avatar for user75414 @user75414

Actions