Unable to flash new Espruino WiFi

Posted on
  • Board came with 1v91 and I would like to upgrade to 1v92. I can't get it into boot loader mode after trying 5 different cables and dozens of attempts. (red and green leds blink once and go out.) Board is working, but I just can't get it into boot loader mode. So now I would like to try advanced flashing I downloaded the windows utility at the link you provided and it installed something called DFuseDemo and when I run it it sees my board (after shorting the pins on the underside with a graphite pencil mark). It will not load a .bin file however, the utility only supports .dfu files. How do I generate or get one of those?

  • After a fumbling around a bit I was able to use the DfuFileMgr to generate a .dfu from the .bin and then selected the upgrade option which it said was successful. Cleaned off the graphite mark and reconnected in the IDE and it still says that I have 1v91. I thought I had it ... suggestions?

    One more thing ... I have confirmed that my button is working, because I wrote some code that would light the LED when button was pressed. Worked like a champ. Push the button and it lights, release and it goes out.

  • What board model is it?

  • Espruino Wifi

  • Sometimes it is difficult to keep the switch pressed while powering / plugging in the micro USB connector. To make it work reliably, I plug the USB cable first to the Espruino Wifi, then press and hold the switch and plug the other end of the cable into the USB connector of my computer.

  • But you used the DFU tool from here and couldn't get it to go? http://www.st.com/en/development-tools/s­tsw-stm32080.html

    If you can get the bootloader working rather than using DFU, that'd definitely be easiest though.

    As @allObjects says, the micro USB connector is quick tight and the button is hard to press, so I generally hold the button while plugging the other end of the USB cable into the PC.

    It's odd about the red & green LEDs flashing though. That should only really happen if the power gets interrupted after the bootloader mode starts.

    Just to help try and rule some things out, please could you try and do it while connected to another PC, and/or a USB charger? On the USB charger the red&green LEDs should be solidly on when in bootloader mode - if that fails then we know something's up with the .

  • I know those micro-usb connectors are fragile, so I try to do all my plugging and unplugging at the PC end of the cable. (I have tried it on two different computers with different cables.) I'm at the office currently, so I'll try the USB Charger test when I get home. I'm having one other problem when I do a require("neopixel"), I'm getting a module not found error and I don't see it in the github repository along with the other modules. Did you forget to commit it to github?

    Gordon, kudos on a great piece of work! I have been doing lots of node.js work over the last 6 months and this feels very similar.

  • Thanks - hope you have some luck getting it going. Did you use the DFU tool linked above when you tried it? Unless ST have changed it somehow, it should have been able to upload the bin file directly.

    The neopixel library is built into the firmwares - but only from 1v92 and onwards. When you manage to update the firmware you'll get it, but I'm afraid there's no way until then.

    On the Espruino WiFi you can still use neopixels directly without the library, but honestly I'd wait - there are lots of other fixes/features in 1v92 that'd be helpful.

  • Using just a USB charger the red and green lights stay on longer (maybe a full second) and then go out. Tried the DefuSeDemo tool again and did an upgrade and it said it was successful, but the version number did not change when I went to the Web IDE. Can you provide some brief step by step instructions on using the DFU tool? I have a feeling I'm just missing a step somewhere and it is uploading the firmware to the wrong place or something.

  • More info ... if I use the utility to make a dfu from the device I still see 1v91 in a hexeditor. Even though the dfu that I'm using for the upgrade save 1v92. Very frustrating.

  • I found this video and it matches what I tried. https://www.youtube.com/watch?v=Kx7yWVi8­kbU

  • Where are you getting the firmware from that you're finding 1v91 in? When I download http://www.espruino.com/binaries/espruin­o_1v92_wifi.bin and search for 1v I see 1v92 in a few places, but no mention of 1v91.

    When you connect the Espruino WiFi and press the button, do you keep the button held down? If you hold the button down then it'll leave the bootloader mode after a second or two - which might be what you're seeing when you plug into USB (it's the only way I can get a device here to light the LEDs for just a second).#

    Can you try plugging in with the button pressed, but releasing the button as soon as the LEDs light?

  • That did it! Worked first try. I never noticed that I needed to release the button immediately after it started flashing. Thank you Gordon!

  • Great! I'll update the instructions in the Web IDE to mention it :)

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

Unable to flash new Espruino WiFi

Posted by Avatar for EricMeyer @EricMeyer

Actions