Can't connect using Espruino Web IDE

Posted on
  • I've tried to connect to Puck.js from a newly reset Windows 10 laptop. Pairing was no problem but the Web IDE (native, v65.9) keeps saying "NO PORTS FOUND".

    It does however show up in the Settings app as well as in the Device Manager under "Bluetooth".

    What I tried already:

    1. Unpair and pair
    2. Update Windows (including Creators Update)
    3. Reinstall Web IDE
    4. Update firmware on Puck.js to v92
    5. Several restarts of both devices

    I also tried some methods to list all connected serial ports but always got back an empty list.

    What could be the problem? What else could I try?

    Here is the console output:

    We have chrome.serial - not using 'serialport' module
    serial_audio: Audio Sample rate : 48000
    serial_audio: Audio Serial Baud 9600 Bit time 5
    No navigator.bluetooth - Web Bluetooth not enabled
    GET = undefined
    Initialising SettingsConsole
    Initialising Utils
    Initialising Config
    Initialising Notifications
    Initialising Status
    Initialising App
    Initialising File
    Initialising Code
    Initialising Serial
      - Initialising Serial Chrome Serial
      - Initialising Serial Chrome Socket
      - Initialising Serial Audio
    Initialising Terminal
    Initialising CodeWriter
    Initialising Modules
    Initialising Env
    Initialising Flasher
    Initialising EditorBlockly
    Initialising EditorJavaScript
    Initialising Send
    Initialising MenuPortSelector
    Initialising MenuSettings
    Initialising MenuFlasher
    Initialising SettingsAbout
    Initialising SettingsFlasher
    Initialising BoardJSON
    Initialising VersionChecker
    Initialising Compiler
    Initialising Assembler
    Initialising GetGitHub
    Initialising NPMModules
    Initialising SetTime
    Initialising Unicode
    Initialising Minify
    Initialising SaveOnSend
    Initialising Tutorial
    Initialising Webcam
    Initialising FontSize
    Initialising UiMode
    Initialising URLHandler
    Initialising CodeLink
    Initialising Project
    Initialising Testing
    Initialising Notification_Sound
    Initialising Tern
    Initialising Debugger
    Initialising Tour
    Initialising SettingsProfile
    Initialising HelpLinks
    Initialising Offline
    No code in storage.
    GET = 0 bytes


  • This might help.

    It runs a background service that makes Bluetooth appear to chrome as web Bluetooth.­305246/#comment13648705

  • Are you sure you're running the 'Espruino IDE' app and not accidentally running the Chrome Web app?

    If you look in the console when running the Native IDE, it should say:

    Initialising Serial
      - Initialising Serial Chrome Serial
      - Initialising Serial Chrome Socket
      - Initialising Windows NUS BLE      <-------------
      - Initialising Serial Audio

    But you don't seem to have that extra line. I just tried running the chrome app and it matches perfectly with your console log.

  • @Gordon You're absolutely right, I didn't notice that Chrome automatically restored the app after I logged in.

    It works perfectly now, thanks for the quick response!


Can't connect using Espruino Web IDE

Posted by Avatar for Thomas @Thomas