nRF52DK board loading

Posted on
  • Hi,

    Until now, I was using a PUCKJS device, for which I have added a library for specific hardware support.
    The library is compiled and linked with Espruino.
    I can load the PUCKJS with this new code through Bluetooth with the nRF toolbox and DFU boot loader.
    All work fine, I can invoque functions in the added library.

    Now I’m trying to use the nRF52 development kit board, which is closed to our target design, and which shall be more convenient for finalization purpose.
    I get some problems for loading the code into this board.

    I have to perform loading in 2 ways:
    1) By directly copying the code into the MBED drive
    2) Through Bluetooth, by using the DFU boot loader as for the PUSKJS

    While I was not sure of the correct state of the board after some unsuccessful load attempts, I decided to update the board firmware, as explained on the ARMmbed site (Boards >> Nordic nRF52-DK):

    • download the binary from Nordic
    • perform a boot reset => BOOTLOADER drive is enumerated
    • copy the firmware to the BOOTLOADER drive
    • wait then power off / power on the board => MBED drive is enumerated

    Next I generated the code for the NRF52832DK board. In a first approach, I removed the specific library I added to the project.

    make clean && BOARD=NRF52832DK RELEASE=1 make
    

    This merges the Espruino code with the SoftDevice and generates the espruino_1v91.599_nrf52832.hex file.
    I then copied the .hex file into the MBED drive.
    The drive automatically dismounts and mounts again.
    I then powered off / powered on the board.
    At this stage, I expected to be able to connect the board through the Espruino WEB IDE, but this is not possible : the board is not advertising and not visible as a Bluetooth device.

    Can you help me for this problem ?

    I also tried to generate a DFU bootloader for the NRF52DK.

    make clean && BOOTLOADER=1 BOARD=NRF52832DK RELEASE=1 make
    

    This first generated several errors because some included files were not found.
    I modified the makefile to add the paths to the missing files and retried the make.
    The make failed again but with undefined references :

    targets/nrf5x_dfu/main.o: In function ‘main’:
    main.c:(.text.startup.main+0x26): undefined reference to ‘nrf_bootloader_init’
    main.c:(.text.startup.main+0x36): undefined reference to ‘nrf_bootloader_app_start’
    

    Is there something wrong in the generation process ?

    So I tried to directly use the DFU boot loader provided in the nRF5 DSK
    I first tried nRF5_SDK_11, which provides 'dfu_dual_bank_ble_s132_pca10040.hex' in examples/dfu/bootloader/hex
    I also tried nRF5_SDK_12, which provides 'secure_dfu_secure_dfu_ble_s132_pca10040­_debug.hex' in examples/dfu/bootloader_secure/pca10040_­debug/hex

    Both files, once loaded (copied into the MBED drive, etc.) make the board visible as DfuTarg in the DFU nRF toolbox.

    I then generated a .zip package for the NRF52DK. For that I had to modify the NRF52832DK.py file by adding the following lines (copied from PUCKJS.py) in the ‘makefile’ section :

    'DFU_PRIVATE_KEY= targets/nrf5x_dfu/dfu_private_key.pem’,
    ‘DFU_SETTINGS=—application-version 0xff —hw-version 52 —sd-req 0x8C’,

    and then make again :

    make clean && DFU_UPDATE_BUILD=1 USE_BOOTLOADER=1 BOARD=NRF52832DK RELEASE=1 make
    

    This generates the 'espruino_1v91.599_nrf52832.zip' package file.
    When I try to load the generated package with the DFU nRF toolbox, it fails.
    With the bootloader from SDK 11, the error is ‘remote DFU data exceeds limit’. Is it due to the fact that it is a dual bank bootloader ?
    With the bootloader from SDK 12, the error is ‘invalid CRC’.

    Thank you for your help for all these problems.

  • I'm sorry but I can't provide free support to help you modify Espruino for use in your commercial product. If you're interested in paying for my time supporting you then I could help though.

    With your initial non-DFU build there may be some issue with your compiler or the code you have added. For example, nrf52dk builds from espruino.com/binaries/travis/­master/ should allow you to just copy the hex file to the mbed drive and they will work straight away. To build them all you need to do is make clean && BOARD=NRF52832DK RELEASE=1 make, so if that's not working I'd start from a fresh, unmodified git project and see if that works.

    If a fresh checkout from Git fails, I'd guess there may be a compiler issue?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

nRF52DK board loading

Posted by Avatar for user75013 @user75013

Actions