• I'm having difficulty updating the firmware on my puckjs. Once in DFUTarg mode;

    • if i try to upload the firmware in NRF Toolbox i get the message "upload failed dfu device disconnected"
    • if i try try to do it using NRF Connect, when I select the device I get a connecting spinner and never get the DFU icon in the menubar shown here youtube.com/watch?v=N3CJbl29­vy0




    Any ideas?

  • Have you tried a fresh battery? The DFU update uses quite a lot of power, so if your battery is on the way out then the DFU process can cause the battery voltage to drop too low, which will make Puck.js reboot

  • Thanks Gordon,

    I left the battery out over the weekend and when I tried updating it today it worked first time.

  • Great! It'd be worth checking 'Puck.getBatteryPercentage()` to get an idea how full it is - if it's running right down then stuff like the Magnetometer might not work.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

Firmware update issue "upload failed dfu device disconnected"

Posted by Avatar for reynish @reynish

Actions