Firmware update failed

Posted on
  • I attempted to runt the puck 1v91 firware update via nRF toolbox and got a notification saying the upload failed. Now the Puck won't seem to switch on. I can't get the red LED for a soft reset or the green LED.

  • Do you think you could check the battery voltage or try with a new battery?

    It's possible that the firmware update failed because the battery ran out - re-flashing the device uses quite a lot of power

  • I've tried a new battery and no success. I haven't got a meter to test the battery, but it is new.

  • Do you have any way of getting hold of a volt meter? The only other person that reported having this problem did actually have 2 flat batteries when they tested.

    If it is broken I'm happy to replace it, but it seems amazingly unlikely - even in the case that the firmware upload failed, you should be able to get into bootloader mode by inserting the battery with the button held down

  • I'm afraid I still don't have a multimeter, but I have tested the batteries in a range of devices and they are working. Still no response from the Puck though.

  • Ok, thanks for checking - I've just sent you an e-mail :)

  • Just an update to this if anyone else has the problem - having got it back, it's exactly as I'd said:
    Flat battery and firmware update failed halfway through

    So just insert a new battery with the button held down, and release the button. The red LED should light as normal for bootloader mode, then you just follow the firmware update instructions again.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Firmware update failed

Posted by Avatar for themarkness @themarkness