Web IDE problems?

Posted on
  • Has anyone had any issues with the new Web IDE? That is, apart from the current lack of code hints?

    Just this morning I had an issue where the IDE screen went white after connecting. I've never had it before so I wonder if it's a Chrome update that's changed something...

    But please let me know if you get this too!

  • Maybe not quite a problem with the screen but strange behavior. I can not download three of my own modules. Two can, and the third one, it does not matter which one - does not load.
    And a weird message in the console:

    .........
    F3C66A9BC06A4E512CEFA4F652750:projects"}­

    • my-gpio-expander requires []
      [notify_info] No error. Minified 1109 bytes to 671 bytes.
    • my-at requires []
      [notify_info] No error. Minified 5452 bytes to 1685 bytes.
      loadModule(my-atsms)
      Searching for modules/my-atsms.min.js
      modules/my-atsms.min.js not found in offline archive
      ERROR: Found module, but search took too long.
      ERROR: getURL("https://www.espruino.com/modules/my-atsm­s.min.js") error : Not Found
      Searching for modules/my-atsms.js
      modules/my-atsms.js not found in offline archive
      ERROR: getURL("https://www.espruino.com/modules/my-atsm­s.js") error : Not Found
      WARNING: [notify_warn] Module my-atsms not found
      Found a prompt... great!
      >>> Sending...
      .......
  • Could you try turning off 'offline mode' in the IDE? That might help you I guess?

  • I work online all the time... By the way, I tried both modes with the same results ...

  • I found a way to circumvent it. I cut the path to the sandbox projects folder. It was "D: \ MyDocum \ MyProjects \ STM32F4-Discovery \ javascript \ projects" and it is now "D: \ MyDocum \ Espruino \ projects". In principle, you need to pay attention to this problem as a bug ...

  • And still it does not find the module from time to time ...

  • I work online all the time...

    But have you turned Enable offline mode on in the IDE's settings? Because as far as I can tell, to get the message ... not found in offline archive you have to have that option turned on.

  • No, I have this option turned off all the time... except that switched on for a short time to check that in this mode it does not work normally too ...

  • I tried an old netbook with windows xp, intel atom and 1GB of RAM and the web IDE practically does not work and does not even see any one module ... Although my main PC is windows 10, intel core i3 and 4 gb RAM, but it seems to me, that it is the problem with the speed of the computer ... What are the basic PC requirements of the Web IDE?

  • The IDE itself works usably on a Raspberry pi which is ~700MHz, 512MB RAM - so I'd have thought the netbook would be ok.

    However the ERROR: Found module, but search took too long. could be related to the speed of the computer. The offline mode being enabled somehow (no idea how if it's not in the settings) won't help though.

    the web IDE practically does not work and does not even see any one module

    What do you mean? You can't connect to the hardware, or it's finding software modules that is the issue?

  • Connect to the hardware seems OK... The console shows lines from previously loaded program, but after the command "Send to Espruino" it completely freezes, so I stopped further attempts with my netbook ...

  • Ok. I just fixed what I hope is the ERROR: Found module, but search took too long error - it seemed to be related to the projects.

    If you download the absolute latest version from https://github.com/espruino/EspruinoWebI­DE then it should work for you.

  • Something I have noticed is that the upload progress bar (right down corner) is almost instant in the new version (0.68.6), while previously it would go more slowly if I remember correctly. I'm just mentioning this because it may reflect some of the problems I'm having when uploading code (>2000 bytes), where I'd get frequent exceptions (even with code that doesn't run while uploading).

    Of course this may be related to my code or have something to do with my system, so it's more possible that this is not related to anything, just a thought. I'm controlling puck through Raspberry Pi btw.

  • Interesting - so you're using the Web IDE on a Raspberry Pi, as a Chrome Web App, or just https://www.espruino.com/ide/ with Web Bluetooth?

    I noticed the progress bar wasn't there on the Windows NW.js port, but assumed that was related to the Noble backend - it's still there for me on the online IDE when using Web Bluetooth.

  • If you download the absolute latest version from https://github.com/espruino/EspruinoWebI­DE then it should work for you.

    Thanks, it works...

  • Great! Hopefully I'll get a proper release out there soon.

  • I'm controlling puck through EspruinoHub on Raspberry Pi Zero W, and raspberrypi.local:1888/ide/ on Chrome (on my pc). As I said, it's probably nothing, just mentioned it because it used to take some seconds for the bar to complete (depending on the size of the code), it would fill gradually, while now it goes instantly to full and then disappears.

  • That really is strange - I just gave it a try through EspruinoHub here and it still works great with the progress bar...

  • @Gordon probably is something related to my system then, not a big deal anyway :)

  • Hi, this is an old thread, however, I face some difficulties with the WebIde as a Chrome application and just the https://www.espruino.com/ide/.
    Here are what they are:
    a- In the WebIde settings>Communications, I have to reselect the last option "Set current time" each time the WedIde is restarted from Android. It seems, it is not saved in this configuration.
    b- The "Project directory for sandbox" button in Settings>Project doesn't display any select box.
    It gets darker a few 1/10 of a second each time i press it. Again that's on Android through the Chrome application and the web served ide https://www.espruino.com/ide/.
    c- Saving (disquette button) displays a disturbing "download" message and doesn't let me choose the file name. I get a code(some number).js file in my download directory.

    My Android version is 7.0.

    I was wondering if there could be some "hidden setting" to properly setup in Chrome?

    Thanks for your attention.

  • a) That's odd - are other options remembered? When running from /ide the Web IDE uses cookies to remember options, and maybe those get lost?

    b) The 'Project' option isn't usable when the IDE is used from a website because Chrome doesn't provide the needed permissions - thanks for letting me know, I'll see about removing the page completely from Settings if it isn't supported.

    c) I think that's an Android issue. save is using the standard way of getting files from a website (https://github.com/espruino/EspruinoWebI­DE/blob/gh-pages/js/core/file.js#L132) so it'll always display the 'download' message - when running on desktop it'll let you choose the filename. I don't know if you/anyone has any ideas - I guess on Android it could pop up a box asking for the filename to use, but that's still not a great user experience.

  • Hi,
    a) Well other options are not always remembered: the minification options for instance are more or less randomly saved, and so does the time set option.

    b) Ok, so this is a feature reserved to the native application: I use the linux one on Ubuntu 16.04.

    c) It's just disapointing and onec I got used, yet some thing to do manually. By the way, I would greatly appreciate having an otion to peridically save the source AND journalise those saves (git commits with automatic commit comment would be nice). I guess, reading your answer, that it won't happen unfortunately.

    Thank's for your answer.

  • I have a bit of an issue with saving in that Chrome's save functionality (for the web app) is rate-limited, so while I tried enabling a periodic save, if I do it too often then I hit the rate limit and it stops saving completely!

    Similar issues have come up quite recently as well, and I think that actually it might make a lot more sense for me to get rid of the cookie-based and chrome app based saving and instead do it via a login account on espruino.com (probably using the same login mechanism as the forum).

    That way I could ensure that the settings really were saved and persisted, but also I could keep a copy of the code in the IDE (without the rate limiting) and could even have the option of having multiple files stored online.

    Files in Git would be really nice - if GitHub provide an API for it, it might actually make sense to just add a plugin to the Web IDE that saved/loaded from Git. It shouldn't be that hard at all.

    However GitHub will almost certainly rate-limit too, so auto-saves are probably out :(

  • Hi again,
    Well now github offers unlimited private projects for free, the restriction is on the number of developpers allowed to participate.
    There is also gitlab which does more or less the same.
    Their rate limits are probably high enough for me as I don't frenetically type on my keyboard :)
    Still we would need some API on their side.
    And finally, I'd prefer a save to a local storage.

  • And finally, I'd prefer a save to a local storage.

    Me too - it's just that the Web Browser really restricts what you can do with local storage, which makes this sort of thing a nightmare. If anyone has example code that works better then I'm happy to try to integrate it in the IDE.

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview
About

Web IDE problems?

Posted by Avatar for Gordon @Gordon

Actions