Posted on
  • Hi,
    New to this so please bare with me.
    Macbook pro (with knackered keyboard) using a wireless Logitech K260 keyboard and mouse mated together with 1 dongle. Everything works fine -i'm typing this- but using the Web IDE the keyboard doesn't seem to work at all or am i doing something else wrong entirely?
    Connected using Terminal and tried this
    It won't connect if i add the 9600 at the end of the screen /dev/tty........... but will if i leave it out?
    The button doesn't work according to the reply =1
    If i use the button on the board it does? faulty something related to above or crap soldering in of legs?
    thanks in advance

  • On the mac book pro (I have a mid 2009 one), the keyboard goes out when too much current is pulled from the USB (a short happened by mistake that caused the USB to dtrigger the fuse). Restart of the laptop get it going again. This could be a cause.

    Can you give a bit more detail how you connect all your things?

  • With the Web IDE, did you click the 'connect' button in the top left? If you're not connected then the terminal won't react.

    Also, you say you used /dev/tty... - what about /dev/cu...? Sometimes I think you may need to use that on Macs.

    It's possible that the Mac is actually trying to take control of the Pico and use it as a modem (you could check in settings and see if that's happening?). It would explain the issues you were having with screen too.

    For the external button, after using pinMode(B4, "input_pulldown");, does digitalRead(B4) return 0 when not pressed and 1 when pressed?

  • allObjects, thanks. It's a bit of crash damage i'm affraid. A cheapo Gumtree purchase and the keyboard sometimes works but sometimes doesn't regardless of any 'load'.
    I got a Logitech combined wireless keyboard/mouse combo that shares usb reciever.

    Gordon - When using terminal i use the /dev/tty..... when i try to connect in the IDE this doesn't come up as an option and i select /dev/cu

    The only i had with 'screen' was resolved by not typing the '9600'at the end of the line when connecting.

    Not sure what to check in my Settings? I don't see the Pico in the 'Network' page

  • Can you try running:

    lsof | grep usbmodem

    and see if that returns anything? It's possible it'll show something using the port...

    The suggestions here may help as well. They are for Arduino, but could apply similarly to Espruino

  • Hi there,
    I tried it and nothing came up
    Thanks anyway

  • sudo mkdir /var/lock
    sudo chmod 777 /var/lock

    This works :) :) :) IDE is working awsome, thanks

  • Button doesn't but i guess thats my shoddy soldering of the headers

  • Great - thanks for letting us know! Strange though... I wonder why your computer was different, as most Macs seems to work without trouble.

    With the button, did you try:

    For the external button, after using 'pinMode(B4, "input_pulldown");', does 'digitalRead(B4)' return 0 when not pressed and 1 when pressed?

    You could always try using a different pin, just to make sure?

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview


Posted by Avatar for user54993 @user54993