Module "NetworkJS" not found

Posted on
  • Hi,

    I got my lovely PICO Ultimate Toy Kit today :-)

    I thought I'd start with trying out the ESP8266, so I soldered it on using the shim.
    I then tried the example code from
    but on sending to espruino I get:

    WARNING: Module "NetworkJS" not found

    I can't see NetworkJS.js in ?
    Any ideas?

    Many thanks


  • NetworkJS should be builtin... (I haven't tried it yet though)­kJS

    Are you using latest firmware version?

  • Nope, I'm seeing the same thing :-/

    Maybe it works in a cutting edge build, but advanced flash firmware doesn't seem to work anymore...

  • Argh. Sorry, I was pretty sure it had for into the release. I'll put a new one out this morning, and will fix the advanced flash too.

  • Ok, all fixed. I just released 1v76 which has a bunch of changes, and fixed the Web IDE (it should auto-update over the next hour or so - but for normal flash updates the old one will work fine).

    Sorry about that - in the rush to get them out I'd forgotten to do the new release. The NetworkJS module is actually built in to Espruino (in 1v76). It lets you write a network device driver in JavaScript (like is done for the ESP8266 now).

    Basically the old built-in driver needed a few tweaks to work with the ESP8266 modules I got for the KickStarter campaign, but it became apparent it was pretty nasty inside. This new one is written in JS and should be a bit easier to change and add to - hopefully it'll also be the start of support for GSM modules as well.

  • Great to see the ESP8266WiFi module done in Javascript. Does NetworkJS require USE_NET in the espruino build?

  • @the1laz yes, it will... I'm including it in all builds (wiznet + cc3000) at the moment, but it's also possible to build without either cc3k or wiznet and still use the ESP8266 (which should free up a bit of RAM and a lot of flash :)

    At some point in the future I may pull the 'AT' module into Espruino, but for now absolutely all the ESP8266 stuff is JS.

  • @Gordon Awesome. Freeing up flash was why I asked.

  • NetworkJS not found error again ! After many years ;; Espruino WiFi board.

  • Are you using up to date firmware? Do you have an example of how/where you get the error? I just tried here with 1v93 and it works great

  • Ok. I see. I reset my flash, put the wifi require in an onInit function, without actually connecting to the WiFi (since I need that at times only). It works now. I understand that the networkJS is a native inbuilt module and bundled with the firmware.

    Thanks so much !

  • Post a reply
    • Bold
    • Italics
    • Link
    • Image
    • List
    • Quote
    • code
    • Preview

Module "NetworkJS" not found

Posted by Avatar for GrahamT @GrahamT