You are reading a single comment by @AkosLukacs and its replies. Click here to read the full conversation.
  • I guess longer file names night be the cause of what I experienced:
    MDBT42Q module, updated to latest build (2v04.377 because why not), tried to upload some code direct to flash (wrote earlier, <50 lines, and known working), and weird messages began:

    >Uncaught Error: File already written with different data
     at line 1 col 1108
    Uncaught Error: Unable to find or create file
     at line 2 col 331
    ... start going forwards",1024);

    Tried uploading to ram, and the code worked just fine.

    Did the usual like reset(1), and when opened the new device storage, I saw two files with names like " , 0!. Looking at it, those were two fragments from my earlier lora experiments. Not full files, just fragments.
    Deleted both of those, reading raw file with Storage module, no files:

    > var st=require('Storage')
    =[  ]

    Try uploading code again, still doesn't work. Same error message. Checking storage again, there is a weird "file" again. Again fragment from earlier code. Now looked at the size, and it's 256 bytes.
    Upload again, and it's working now.

    Totally forgot about longer file names in three days, almost started a new forum thread when remembered this. I think some robust detection of earlier saved code & deletion could reduce support requests :)


Avatar for AkosLukacs @AkosLukacs started