• Puck -> tried it with Chrome

    That's a shame. I'll have to try it on some more platforms and see if I can figure out what's up. Personally I tend to use the app, but I've found the online IDE seemed to work pretty well for me (you did connect to the 'DfuTarg' device?).

    the latest master build doesn't have either.

    Yes, I don't bother doing CC3000 builds for every commit. The chip is EOL so very few people will be using it.

  • Yes, connected to "DfuTarg", the LED changed immediately, but stuck there forever. Like Robin's second screenshot. But I had no issue like him with connecting and pairing. It was straight forward up to the last point.

    But: Tried to capture traffic with nRF sniffer, of course failed to capture on the first try :) But Chrome started uploading. And then stopped at about 75% (and the "Software Reporter Tool" started eating my CPU). Eventually killed Chrome, and the Puck was working after a reboot. I don't know if the update succeeded, just the progress bar didn't update. Or what's going on. AFAIK, there is no OTA recovery partition in the Puck, right?
    (Or maybe an issue with chrome itself. In the latest chrome canary I can't even select device in the connect to BLE dialog, so there are bugs)


Avatar for AkosLukacs @AkosLukacs started