• Something is not right with the Web Ide: Tried to update my new Puck, update started, but nothing happened for several minutes. Tried it 3 times, no luck (last time I waited for 5 minutes). But I could connect to the puck every time.

    One thing seems to be off: The web Ide was displaying Updating application: espruino_2v04_puckjs_app.bin... (note the .bin extension)

    After that I just used nRF Connect on my phone, and updated just fine, and works just fine.
    I'm on Win10, and now used the Edge dev version (chromium based).

    Oh, and 1 more confusing thing: Pico firmware update with the Web Ide asks me to choose from a firmware with either WIZNet W5500 or TI CC3000 networking. There is no "I don't want networking" option.
    Looks like the build is missing from the downloads as well. But looks like there is a binary at the CI builds

    So I just did a "Advanced Firmware Update" from the Web IDE with https://www.espruino.com/binaries/travisĀ­/master/espruino_2v04_pico_1r3.bin and worked just fine.
    (Win10, Vivaldi Browser with Web Serial)


Avatar for AkosLukacs @AkosLukacs started