You are reading a single comment by @Arman and its replies. Click here to read the full conversation.
  • I used one of the GPIO pins and made an LED blink. The code was running well, so I added save() to the end of my code to make it permanent, but the LED only remained on and none of the pins worked anymore. So I a few things for cleaning the save data, like reset() or as documentation has suggested, pressing the two physical buttons at the same time. When none of these worked, I assumed flashing the device will turn it back to its original condition but now I get this:

    >{ll|dà|Ädìb<ì{ÛcÄ#óoglgoãìcpì${$sdpònàdcoã|lälcû'oîd$`'ÇlorÇ'ld`8ûgàrÜãàc'ã|äcÄò'oïd`ng$'{gl xóoà{ãàäcgã|lcûgnçl`'l`o;Ç'{d`{or$`sdÄgóogãs'olcÇb8dc$älìl$l~;lìddlgâ$$l$äloàgä'dlàÀcßcÛc{ccbdlngÛãol|dl {$rl§Loading -491521 bytes from flash...
     ets Jan  8 2013,rst cause:4, boot mode:(3,7)
    wdt reset
    load 0x40100000, len 1396, room 16
    tail 4
    chksum 0x89
    load 0x3ffe8000, len 776, room 4
    tail 4
    chksum 0xe8
    load 0x3ffe8308, len 540, room 4
    tail 8
    chksum 0xc0
    csum 0xc0
    2nd boot version : 1.4(b1)
      SPI Speed      : 40MHz
      SPI Mode       : QIO
      SPI Flash Size & Map: 4Mbit(256KB+256KB)
    jump to run user1 @ 1000
    don't use rtc mem data
    {$OÿLoading -491521 bytes from flash...

    and then nothing.
    I tried to flash it a few more times trying both sets of parameters written in tutorial page with esptool (just as I did in the first place and worked well) but it seems something wrong has remained on the board


Avatar for Arman @Arman started